PHPLIB remote script execution

phplib-script-execution (6892) The risk level is classified as HighHigh Risk

Description:

The PHP Base Library (PHPLIB) could allow a remote attacker to execute scripts from another host. PHPLIB allows a remote attacker to supply a value for the array element $_PHPLIB[libdir]. An attacker can use this vulnerability to gain access to the Web server.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of IMP (2.2.6 or later) or Horde (1.2.6 or later), available from the Horde Web site. See References.

For Conectiva Linux 4.1:
Upgrade to the latest version of IMP (2.2.6-1U41_2cl or later) or Horde (1.2.6-1U41_1cl or later), as listed in Conectiva Linux Security Announcement CLA-2001:410. See References.

For Conectiva Linux 4.2:
Upgrade to the latest version of IMP (2.2.6-1U42_2cl or later) or Horde (1.2.6-1U42_1cl or later), as listed in Conectiva Linux Security Announcement CLA-2001:410. See References.

For Conectiva Linux 5.0:
Upgrade to the latest version of IMP (2.2.6-1U50_2cl or later) or Horde (1.2.6-1U50_1cl or later), as listed in Conectiva Linux Security Announcement CLA-2001:410. See References.

For Conectiva Linux 5.1:
Upgrade to the latest version of IMP (2.2.6-1U51_2cl or later) or Horde (1.2.6-1U51_1cl or later), as listed in Conectiva Linux Security Announcement CLA-2001:410. See References.

For Conectiva Linux 6.0:
Upgrade to the latest version of IMP (2.2.6-1U60_2cl or later) or Horde (1.2.6-1U60_2cl or later), as listed in Conectiva Linux Security Announcement CLA-2001:410. See References.

For Conectiva Linux 7.0:
Upgrade to the latest version of IMP (2.2.6-1U70_2cl or later) or Horde (1.2.6-1U70_2cl or later), as listed in Conectiva Linux Security Announcement CLA-2001:410. See References.

For Trustix Secure Linux 1.01, 1.1, 1.2, and 1.5:
Upgrade to the latest version of PHPLIB (7.2d-1tr or later), as listed in Trustix Secure Linux Security Advisory #2001-0014. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 4.1
  • Conectiva Linux 4.2
  • Conectiva Linux 5.0
  • Conectiva Linux 5.1
  • Conectiva Linux 6.0
  • Conectiva Linux 7.0
  • Debian Debian Linux 2.2
  • Horde Horde 1.2.5
  • Horde IMP 2.2.5
  • Trustix Secure Linux 1.01
  • Trustix Secure Linux 1.1
  • Trustix Secure Linux 1.2
  • Trustix Secure Linux 1.5

Reported:

Jul 21, 2001

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page