Horde IMP cross-site scripting

imp-cross-site-scripting (6905) The risk level is classified as MediumMedium Risk

Description:

Horde IMP (Internet Messaging Program) is vulnerable to cross-site scripting, caused by embedded JavaScript within email messages. A remote attacker could use the IMP Web mail interface to send emails containing malicious JavaScript, which are executed in the victim's Web browser once the message is received.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of IMP (2.2.6 or later), available from the Horde Web site. See References.

For Conectiva Linux 4.1and 4.2:
Upgrade to the latest version of IMP (2.2.6-1U41_2cl or later), as listed in Conectiva Linux Security Announcement CLA-2001:410. See References.

For Conectiva Linux 5.0:
Upgrade to the latest version of IMP (2.2.6-1U50_2cl or later), as listed in Conectiva Linux Security Announcement CLA-2001:410. See References.

For Conectiva Linux 5.1:
Upgrade to the latest version of IMP (2.2.6-1U51_2cl or later), as listed in Conectiva Linux Security Announcement CLA-2001:410. See References.

For Conectiva Linux 6.0:
Upgrade to the latest version of IMP (2.2.6-1U60_2cl or later), as listed in Conectiva Linux Security Announcement CLA-2001:410. See References.

For Conectiva Linux 7.0:
Upgrade to the latest version of IMP (2.2.6-1U70_2cl or later), as listed in Conectiva Linux Security Announcement CLA-2001:410. See References.

For Caldera OpenLinux Server 3.1:
Upgrade to the latest version of IMP (2.2.6-1 or later) and Horde (1.2.6-1 or later), as listed in Caldera International, Inc. Security Advisory CSSA-2001-027.0. See References.

For Debian GNU/Linux 2.2:
Upgrade to the latest version of IMP (2.2.6-0.potato.1 or later) and Horde (1.2.6-0.potato.1 or later), as listed in DSA-073-1. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 4.1
  • Conectiva Linux 4.2
  • Conectiva Linux 5.0
  • Conectiva Linux 5.1
  • Conectiva Linux 6.0
  • Conectiva Linux 7.0
  • Debian Debian Linux 2.2
  • Horde IMP 2.2.5
  • SCO Caldera OpenLinux Server 3.1

Reported:

Jul 21, 2001

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page