PHP Booking Calendar details_view.php cross-site scripting

phpbookingcalendar-detailsview-xss (71883) The risk level is classified as MediumMedium Risk

Description:

PHP Booking Calendar is vulnerable to cross-site scripting, caused by improper validation of user-supplied input by the details_view.php script. A remote attacker could exploit this vulnerability using the page_info_message parameter in a specially-crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.

*CVSS:

Base Score: 4.3
  Access Vector: Network
  Access Complexity: Medium
  Authentication: None
  Confidentiality Impact: None
  Integrity Impact: Partial
  Availability Impact: None
 
Temporal Score: 4.1
  Exploitability: High
  Remediation Level: Unavailable
  Report Confidence: Uncorroborated

Consequences:

Gain Access

Remedy:

No remedy available as of October 1, 2014.

References:

Platforms Affected:

  • PHP Booking Calendar PHP Booking Calendar 10e

Reported:

Dec 18, 2011

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page