HP 9000 large user and group IDs privilege escalation

hp-large-uid-gid (7594) The risk level is classified as HighHigh Risk

Description:

Some programs on HP 9000 series 700/800 systems running HP-UX do not properly interpret UIDs and GIDs greater than 60000. An attacker could use a vulnerable program to gain privileges, including root access.


Consequences:

Gain Access

Remedy:

Apply the appropriate patch for your system, as listed in Hewlett-Packard Security Bulletin HPSBUX9611-041. See References

Note: Scan and examine your systems for suid files that may not be safe for a large UID/GID system. Certify that all program are safe to use in large UID/GID systems. Remove or restrict execute privileges for programs that may be unsafe.

References:

Platforms Affected:

  • HP HP-UX 10.20

Reported:

Nov 21, 1996

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page