Linux groff preprocessor buffer overflow

linux-groff-preprocessor-bo (7881) The risk level is classified as HighHigh Risk

Description:

The groff package is vulnerable to a buffer overflow in the preprocessor. If the line printer daemon (lpd) is running, a remote attacker could send a specially-crafted print request to the groff preprocessor using the LPRng printing system to overflow a buffer and execute arbitrary commands on the system with privileges of the lp user.


Consequences:

Gain Access

Remedy:

For Red Hat Linux 7.0:
Upgrade to the latest version of groff (1.16-7.1 or later), as listed in Red Hat Linux Errata Advisory RHSA-2002:004-07. See References.

For Red Hat Linux 7.1 and 7.2:
Upgrade to the latest version of groff (1.17.2-7.0.2 or later), as listed in Red Hat Linux Errata Advisory RHSA-2002:004-07. See References.

For Mandrake Linux 7.2, 8.0, and Single Network Firewall 7.2:
Upgrade to the latest version of groff (1.16.1-7.2mdk or later), as listed in MandrakeSoft Security Advisory MDKSA-2002:012 : groff. See References.

For Mandrake Linux 8.1:
Upgrade to the latest version of groff (1.17.2-3.3mdk or later), as listed in MandrakeSoft Security Advisory MDKSA-2002:012 : groff. See References.

For Gentoo Linux: Upgrade versions sys-apps/groff-1.17.2-r2 and earlier, as listed in Gentoo Linux Security Announcement 2002-10-19 19:30 UTC. See References.

For Caldera OpenLinux 3.1 and 3.1.1 (Workstation and Server):
Upgrade to the latest groff package (1.17.2-3 or later), as listed in SCO Security Advisory CSSA-2002-057.0. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Gentoo Linux
  • GNU Groff
  • MandrakeSoft Mandrake Linux 7.2
  • MandrakeSoft Mandrake Linux 8.0 PPC
  • MandrakeSoft Mandrake Linux 8.0
  • MandrakeSoft Mandrake Linux 8.1 IA64
  • MandrakeSoft Mandrake Linux 8.1
  • MandrakeSoft Mandrake Single Network Firewall 7.2
  • RedHat Linux 7
  • RedHat Linux 7.1
  • RedHat Linux 7.2
  • RedHat Linux 7.3
  • SCO Caldera OpenLinux Server 3.1
  • SCO Caldera OpenLinux Server 3.1.1
  • SCO Caldera OpenLinux Workstation 3.1
  • SCO Caldera OpenLinux Workstation 3.1.1

Reported:

Jan 07, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page