FFmpeg adpcm_decode_frame code execution

ffmpeg-adpcmdecodeframe-code-exec (78932) The risk level is classified as HighHigh Risk

Description:

FFmpeg could allow a remote attacker to execute arbitrary code on the system, caused by an error in the adpcm_decode_frame function. By persuading a victim to open a specially-crafted ADPCM file, an attacker could exploit this vulnerability to execute arbitrary code on the system or cause the application to crash.

*CVSS:

Base Score: 6.8
  Access Vector: Network
  Access Complexity: Medium
  Authentication: None
  Confidentiality Impact: Partial
  Integrity Impact: Partial
  Availability Impact: Partial
 
Temporal Score: 5
  Exploitability: Unproven
  Remediation Level: Official-Fix
  Report Confidence: Confirmed

Consequences:

Gain Access

Remedy:

Upgrade to the latest version of FFmpeg (0.9.1 or later), available from the FFmpeg Web site. See References.

References:

  • FFmpeg Web site: FFmpeg Security.
  • oss-sec mailing list, Tue, 14 Feb 2012 13:54:18 -0700: CVE Requests for FFmpeg 0.9.1.
  • CVE-2012-0852: The adpcm_decode_frame function in adpcm.c in libavcodec in FFmpeg before 0.9.1 and in Libav 0.5.x before 0.5.9, 0.6.x before 0.6.6, 0.7.x before 0.7.6, and 0.8.x before 0.8.3 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via an ADPCM file with the number of channels not equal to two.
  • DSA-2494: ffmpeg -- several vulnerabilities

Platforms Affected:

  • Ffmpeg Ffmpeg 0.7.1
  • Ffmpeg Ffmpeg 0.7.11
  • Ffmpeg Ffmpeg 0.7.12
  • FFmpeg FFmpeg 0.7.2
  • FFmpeg FFmpeg 0.7.7
  • Ffmpeg Ffmpeg 0.7.8
  • Ffmpeg Ffmpeg 0.7.9
  • Ffmpeg Ffmpeg 0.8.10
  • Ffmpeg Ffmpeg 0.8.11
  • Ffmpeg Ffmpeg 0.8.5
  • FFmpeg FFmpeg 0.8.6
  • FFmpeg FFmpeg 0.8.7
  • Ffmpeg Ffmpeg 0.8.8
  • FFmpeg FFmpeg 0.9
  • Libav Libav 0.5
  • Libav Libav 0.5.1
  • Libav Libav 0.5.2
  • Libav Libav 0.5.3
  • Libav Libav 0.5.4
  • Libav Libav 0.5.5
  • Libav Libav 0.5.6
  • Libav Libav 0.5.7
  • Libav Libav 0.6
  • Libav Libav 0.6.1
  • Libav Libav 0.6.2
  • Libav Libav 0.6.3
  • Libav Libav 0.6.4
  • Libav Libav 0.6.5
  • Libav Libav 0.7
  • Libav Libav 0.7.1
  • Libav Libav 0.7.2
  • Libav Libav 0.7.3
  • Libav Libav 0.7.4
  • Libav Libav 0.7.5
  • Libav Libav 0.8
  • Libav Libav 0.8 Beta2
  • Libav Libav 0.8.1
  • Libav Libav 0.8.2

Reported:

Feb 14, 2012

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page