Linux /usr/bin/at command invalid execution time heap corruption

linux-at-exetime-heap-corruption (7909) The risk level is classified as HighHigh Risk

Description:

The Linux /usr/bin/at command is used to specify commands from the command line to be executed at a later time. The (at) command is vulnerable to a heap corruption, caused by an error in the parsing routine, which results in the same memory location to be allocated twice. A local attacker could specify an (at) command with an invalid execution time, which would cause a heap corruption that may allow the attacker to gain root privileges on the system.


Consequences:

Gain Privileges

Remedy:

For SuSE Linux 6.4, 7.1, and 7.2 (i386 Intel):
Upgrade to the latest version of at (3.1.8-458 or later), as listed in SuSE Security Announcement SuSE-SA:2002:003. See References.

For SuSE Linux 7.0 and 7.3 (i386 Intel):
Upgrade to the latest version of at (3.1.8-459 or later), as listed in SuSE Security Announcement SuSE-SA:2002:003. See References.

For SuSE Linux 7.1 and 7.3 (Sparc):
Upgrade to the latest version of at (3.1.8-356 or later), as listed in SuSE Security Announcement SuSE-SA:2002:003. See References.

For SuSE Linux 7.0 (Sparc):
Upgrade to the latest version of at (3.1.8-357 or later), as listed in SuSE Security Announcement SuSE-SA:2002:003. See References.

For SuSE Linux 6.4 and 7.0 (AXP Alpha):
Upgrade to the latest version of at (3.1.8-361 or later), as listed in SuSE Security Announcement SuSE-SA:2002:003. See References.

For SuSE Linux 7.1 (AXP Alpha):
Upgrade to the latest version of at (3.1.8-360 or later), as listed in SuSE Security Announcement SuSE-SA:2002:003. See References.

For SuSE Linux 6.4, 7.0, 7.1 (PPC Power PC):
Upgrade to the latest version of at (3.1.8-362 or later), as listed in SuSE Security Announcement SuSE-SA:2002:003. See References.

For SuSE Linux 7.3 (PPC Power PC):
Upgrade to the latest version of at (3.1.8-363 or later), as listed in SuSE Security Announcement SuSE-SA:2002:003. See References.

For Debian GNU/Linux 2.2 (potato):
Upgrade to the latest version of at (3.1.8-10.1 or later), as listed in DSA-102-1. See References.

For Red Hat Linux 6.2:
Upgrade to the latest version of at (3.1.8-22.1 or later), as listed in Red Hat Linux Errata Advisory RHSA-2002:015-13. See References.

For Red Hat Linux 7.0, 7.1, and 7.2:
Upgrade to the latest version of at (3.1.8-23 or later), as listed in Red Hat Linux Errata Advisory RHSA-2002:015-13. See References.

For HP Secure OS Software for Linux 1.0:
Apply the RPMs from RHSA-2002-015, as listed in Hewlett-Packard Company Security Bulletin HPSBTL0201-021. See References.

For Mandrake Linux 8.1:
Upgrade to the latest version of at (3.1.8-4.1mdk or later), as listed in MandrakeSoft Security Advisory MDKSA-2002:007 : at. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Debian Debian Linux 2.2
  • HP Secure OS 1.0
  • MandrakeSoft Mandrake Linux 8.1
  • RedHat Linux 6.2
  • RedHat Linux 7
  • RedHat Linux 7.1
  • RedHat Linux 7.2
  • RedHat Linux 7.3
  • SUSE SuSE Linux 6.4
  • SUSE SuSE Linux 7.0
  • SUSE SuSE Linux 7.1
  • SUSE SuSE Linux 7.2
  • SUSE SuSE Linux 7.3

Reported:

Jan 16, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page