AContent preview_top.php cross-site scripting

acontent-previewtop-xss (79463) The risk level is classified as MediumMedium Risk

Description:

AContent is vulnerable to cross-site scripting, caused by improper validation of user-supplied input by the preview_top.php script. A remote attacker could exploit this vulnerability using the pathext, popup, framed, and file parameters in a specially-crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.

*CVSS:

Base Score: 4.3
  Access Vector: Network
  Access Complexity: Medium
  Authentication: None
  Confidentiality Impact: None
  Integrity Impact: Partial
  Availability Impact: None
 
Temporal Score: 3.7
  Exploitability: High
  Remediation Level: Official-Fix
  Report Confidence: Confirmed

Consequences:

Gain Access

Remedy:

Apply the patch for this vulnerability, available from the AContent Web site. See References.

References:

  • AContent Web Site: AContent.
  • HTB23117: Multiple vulnerabilities in AContent.
  • Offensive Security Exploit Database [10-22-2012]: ATutor 1.2 Multiple Vulnerabilities.
  • Packetstorm Security Website: ATutor AContent 1.2 XSS / Authentication / SQL Injection.
  • BID-56100: AContent Multiple Remote Security Vulnerabilities
  • CVE-2012-5169: Multiple cross-site scripting (XSS) vulnerabilities in file_manager/preview_top.php in ATutor AContent before 1.2-2 allow remote attackers to inject arbitrary web script or HTML via the (1) pathext, (2) popup, (3) framed, or (4) file parameter.
  • OSVDB ID: 86426: AContent file_manager/preview_top.php Multiple Parameter XSS
  • SA51034: AContent Cross-Site Scripting and SQL Injection Vulnerabilities

Platforms Affected:

  • ATutor AContent 1.2

Reported:

Oct 17, 2012

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page