PaintBBS has insecure default permissions

paintbbs-insecure-permissions (7982) The risk level is classified as LowLow Risk

Description:

PaintBBS has default insecure permissions on some files and folders. The /oekaki/ directory and the oekakibbs.conf file are world-readable, which could allow a remote attacker to obtain sensitive information, including the encrypted administrator password.


Consequences:

Obtain Information

Remedy:

No remedy available as of August 1, 2014.

References:

  • BugTraq Mailing List, Tue Jan 22 2002 - 22:45:01 CST: Vulnerabilty in PaintBBS v1.2.
  • BID-3948: PaintBBS Insecure Default Permissions Vulnerability
  • CVE-2002-0202: PaintBBS 1.2 installs certain files and directories with insecure permissions, which allows local users to (1) obtain the encrypted server password via the world-readable oekakibbs.conf file, or (2) modify the server configuration via the world-writeable /oekaki/ folder.
  • OSVDB ID: 5692: PaintBBS oekaki World Writable Directory

Platforms Affected:

  • Oekaki shi-BBS PaintBBS 1.2

Reported:

Jan 23, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page