wmtv local buffer overflows

wmtv-local-bo (8111) The risk level is classified as HighHigh Risk

Description:

wmtv is vulnerable to several buffer overflow vulnerabilities. A local attacker could overflow a buffer and execute arbitrary code on the system with root privileges.


Consequences:

Gain Privileges

Remedy:

For Debian GNU/Linux 2.2 (potato):
Upgrade to the latest version of wmtv (0.6.5-2potato2 or later), as listed in DSA-108-1. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • BID-4054: WMTV Buffer Overflow Vulnerability
  • CVE-2002-0247: Buffer overflows in wmtv 0.6.5 and earlier may allow local users to gain privileges.
  • DSA-108: wmtv -- symlink vulnerability
  • OSVDB ID: 12329: wmtv Multiple Unspecified Overflows

Platforms Affected:

  • Debian Debian Linux 2.2
  • wliang wmtv 0.6.5

Reported:

Feb 07, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page