Ubuntu pam-xdg-support module privilege escalation

ubuntu-cve20131052-priv-esc (82918) The risk level is classified as HighHigh Risk

Description:

The Ubuntu pam-xdg-support module could allow a local attacker to gain elevated privileges on the system, caused by the improper handling of the PATH environment variable. An attacker could exploit this vulnerability to execute arbitrary code with elevated privileges.

*CVSS:

Base Score: 4.6
  Access Vector: Local
  Access Complexity: Low
  Authentication: None
  Confidentiality Impact: Partial
  Integrity Impact: Partial
  Availability Impact: Partial
 
Temporal Score: 3.4
  Exploitability: Unproven
  Remediation Level: Official-Fix
  Report Confidence: Confirmed

Consequences:

Gain Privileges

Remedy:

Refer to USN-1766-1 for patch, upgrade or suggested workaround information. See References.

References:

  • USN-1766-1: pam-xdg-support vulnerability.
  • BID-58550: Ubuntu 'pam-xdg-support' Module CVE-2013-1052 Local Privilege Escalation Vulnerability
  • CVE-2013-1052: pam-xdg-support, as used in Ubuntu 12.10, does not properly handle the PATH environment variable, which allows local users to gain privileges via unspecified vectors related to sudo.

Platforms Affected:

  • Canonical Ubuntu 12.10

Reported:

Mar 18, 2013

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page