CFS (Cryptographic File System) has multiple buffer overflows

cfs-bo (8330) The risk level is classified as HighHigh Risk

Description:

Cryptographic File System (CFS) is vulnerable to several buffer overflows. A remote attacker could overflow a buffer to crash the system or gain root privileges on the system.


Consequences:

Denial of Service

Remedy:

Debian GNU/Linux 2.2 (potato):
Upgrade to the latest version of CFS (1.3.3-8.1 or later), as listed in DSA-116-1. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

  • BID-4219: CFS Multiple Buffer Overflow Vulnerabilities
  • CVE-2002-0351: Buffer overflows in CFS daemon (cfsd) before 1.3.3-8.1, and 1.4x before 1.4.1-5, allow remote attackers to cause a denial of service and possibly execute arbitrary code.
  • DSA-116: cfs -- buffer overflow
  • OSVDB ID: 14405: Cryptographic File System (CFS) cfsd Multiple Unspecified Remote Overflows

Platforms Affected:

  • Debian Debian Linux 2.2
  • Tobias Oetiker CFS prior to 1.3.3

Reported:

Mar 02, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page