BG GUESTBOOK metacharacters in post form allows cross-site scripting

bgguestbook-post-xss (8474) The risk level is classified as HighHigh Risk

Description:

BG GUESTBOOK is vulnerable to a cross-site scripting attack. A vulnerability regarding the lack of metacharacter filtering in user-supplied input could allow a remote attacker to submit a specially-crafted post form containing metacharacters and arbitrary code in any input field, such as name, email, AIM, location, Web site, or message. The malicious code would be executed when a visitor browses the guestbook's main page.


Consequences:

Gain Privileges

Remedy:

Upgrade to the latest version of BG GUESTBOOK (1.1 or later), available from the BG GUESTBOOK HOMEPAGE. See References.

References:

  • BugTraq Mailing List, Sat Mar 16 2002 - 17:10:03 CST: [ARL02-A08] BG Guestbook Cross Site Scripting Vulnerability.
  • BID-4308: BG Guestbook Cross-Agent Scripting Vulnerability
  • CVE-2002-0457: Cross-site scripting vulnerability in signgbook.php for BG GuestBook 1.0 allows remote attackers to execute arbitrary Javascript via encoded tags such as <, >, and & in fields such as (1) name, (2) email, (3) AIM screen name, (4) website, (5) location, or (6) message.
  • OSVDB ID: 7221: BG GuestBook signgbook.php Multiple Parameter XSS

Platforms Affected:

  • BIllYG Productions BG GUESTBOOK prior to 1.1

Reported:

Mar 16, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page