news-tnk metacharacters in "Web" input allows cross-site scripting

newstnk-web-xss (8477) The risk level is classified as HighHigh Risk

Description:

news-tnk is vulnerable to a cross-site scripting attack. A vulnerability regarding the lack of metacharacter filtering in user-supplied input could allow a remote attacker to submit a specially-crafted "Web" field containing metacharacters and arbitrary code. The code would be executed on the system when a visitor browses the malicious news message page.


Consequences:

Gain Privileges

Remedy:

Upgrade to the latest version of news-tnk (1.2.2 or later), available from the Linux-Sottises Web site. See References.

References:

Platforms Affected:

  • Linux-sottises news-tnk 1.2.1

Reported:

Mar 17, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page