SGI IRIX XFS application denial service

irix-xfs-dos (8839) The risk level is classified as LowLow Risk

Description:

IRIX XFS file system is vulnerable to a denial of service attack against any program on the system. The XFS file system is the default file system for IRIX 6.5.x. In SGI IRIX versions 6.5 through 6.5.1, if a local attacker could create a malicious file, the attacker would cause any program that attempts to access the file system to hang.


Consequences:

Denial of Service

Remedy:

Upgrade to the latest version of SGI IRIX (6.5.15 or later), as listed in SGI Security Advisory 20020402-01-P. See References.

References:

  • SGI Security Advisory 20020402-01-P: IRIX XFS filesystem denial of service attack.
  • BID-4511: IRIX XFS Filesystem Local Denial of Service Attack
  • CVE-2002-0042: Vulnerability in the XFS file system for SGI IRIX before 6.5.12 allows local users to cause a denial of service (hang) by creating a file that is not properly processed by XFS.
  • OSVDB ID: 5417: IRIX XFS File System Malformed File DoS

Platforms Affected:

  • SGI IRIX 6.5
  • SGI IRIX 6.5.1
  • SGI IRIX 6.5.10f
  • SGI IRIX 6.5.10m
  • SGI IRIX 6.5.11f
  • SGI IRIX 6.5.11m
  • SGI IRIX 6.5.2
  • SGI IRIX 6.5.3
  • SGI IRIX 6.5.4
  • SGI IRIX 6.5.5
  • SGI IRIX 6.5.6
  • SGI IRIX 6.5.7
  • SGI IRIX 6.5.8
  • SGI IRIX 6.5.9

Reported:

Apr 15, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page