IBM GSKit denial of service

ibm-gskit-cve20136747-dos (89863) The risk level is classified as HighHigh Risk

Description:

IBM Security Directory Server (ISDS) and IBM Tivoli Directory Server (TDS) are vulnerable to a denial of service, caused by an error in the Global Security Toolkit (GSKit) component. By initiating an SSL/TLS connection using a malformed certificate chain, a remote attacker could exploit this vulnerability to cause the server process to hang or crash.

*CVSS:

Base Score: 7.1
  Access Vector: Network
  Access Complexity: Medium
  Authentication: None
  Confidentiality Impact: None
  Integrity Impact: None
  Availability Impact: Complete
 
Temporal Score: 5.3
  Exploitability: Unproven
  Remediation Level: Official-Fix
  Report Confidence: Confirmed

Consequences:

Denial of Service

Remedy:

Refer to the IBM Security Bulletin for patch, upgrade or suggested workaround information. See References.

For other distributions:
Apply the appropriate update for your system. See References.

References:

  • IBM Security Bulletin 1662006: Vulnerabilities in ClearCase GSKit Component (CVE-2013-6747).
  • IBM Security Bulletin 1662902: GSKit certificate chain vulnerability in IBM Security Directory Server and Tivoli Directory Server (CVE-2013-6747).
  • IBM Security Bulletin 1663428: Tivoli Netcool/OMNIbus can be affected by vulnerabilities in the IBM GSKit library.
  • IBM Security Bulletin 1663941: Security Bulletin: Potential Security vulnerability in IBM HTTP Server CVE-2013-6747.
  • IBM Security Bulletin 1664756: IBM GSKit Certificate Chain Vulnerability in IBM Security Access Manager for Web Gateway Appliance (CVE-2013-6747).
  • IBM Security Bulletin 1665137: GSKit Certificate Chain Vulnerability.
  • IBM Security Bulletin 1666421: IBM Security Bulletin: Vulnerabilities in ClearQuest GSKit Component (CVE-2013-6747) - United States.
  • IBM Security Bulletin 1668345: Tivoli Netcool/OMNIbus Web GUI Potential Security vulnerability in IBM HTTP Server CVE-2013-6747.
  • IBM Security Bulletin 1668535: IBM Security Bulletin: Content Manager Enterprise Edition and GSKit Vulnerability (CVE-2013-6747) - United States.
  • BID-65156: Multiple IBM Products CVE-2013-6747 Denial of Service Vulnerability
  • CVE-2013-6747: IBM GSKit 7.x before 7.0.4.48 and 8.x before 8.0.50.16, as used in IBM Security Directory Server (ISDS) and Tivoli Directory Server (TDS), allows remote attackers to cause a denial of service (application crash or hang) via a malformed X.509 certificate chain.
  • SA56403: IBM Tivoli Access Manager for e-business GSKit Denial of Service Vulnerability
  • SA56662: IBM HTTP Server GSKit Denial of Service Vulnerability
  • SA56698: IBM Global Security ToolKit Malformed Certificate Chain Denial of Service Vulnerability
  • SA56699: IBM Global Security ToolKit Malformed Certificate Chain Denial of Service Vulnerability
  • SA56976: IBM Security Access Manager for Web GSKit Denial of Service Vulnerability
  • SA57521: IBM Rational ClearQuest GSKit Denial of Service Vulnerability
  • SA57860: IBM TXSeries for Multiplatforms GSKit Malformed Certificate Chain Denial of Service Vulnerability
  • SA58066: IBM License Metric Tool / Tivoli Asset Discovery for Distributed GSKit Denial of Service Vulnerability

Platforms Affected:

  • IBM Content Manager Enterprise 8.4
  • IBM Content Manager Enterprise 8.5
  • IBM GSKit
  • IBM Rational ClearCase 7.1
  • IBM Rational ClearCase 8.0
  • IBM Rational ClearQuest 7.1.1
  • IBM Rational ClearQuest 7.1.2
  • IBM Rational ClearQuest 8.0.0
  • IBM Rational ClearQuest 8.0.1
  • IBM Security Access Manager for Web 7.0
  • IBM Security Directory Server 6.1
  • IBM Security Directory Server 6.2
  • IBM Security Directory Server 6.3
  • IBM Security Directory Server 6.3.1
  • IBM Tivoli Netcool/OMNIbus 7.2.1
  • IBM Tivoli Netcool/OMNIbus 7.3.1
  • IBM Tivoli Netcool/OMNIbus 7.4.0
  • IBM Tivoli Netcool/OMNIbus Web GUI 7.3.0
  • IBM Tivoli Netcool/OMNIbus Web GUI 7.3.1
  • IBM Tivoli Netcool/OMNIbus Web GUI 7.4.0
  • IBM WebSphere Application Server 6.1
  • IBM WebSphere Application Server 7.0
  • IBM WebSphere Application Server 8.0
  • IBM WebSphere Application Server 8.5
  • IBM WebSphere Application Server 8.5.5
  • IBM WebSphere MQ 7.0
  • IBM WebSphere MQ 7.1
  • IBM WebSphere MQ 7.5

Reported:

Jan 24, 2014

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page