squid_auth_ldap logging() format string

squidauthldap-logging-format-string (9019) The risk level is classified as HighHigh Risk

Description:

The squid_auth_ldap module is vulnerable to a format string attack. A remote attacker could supply a malicious format string in a call to the logging() function, which could allow the attacker to execute arbitrary code on the system with elevated privileges.


Consequences:

Gain Access

Remedy:

No remedy available as of September 1, 2014.

References:

  • Blackshell Advisory # 5: Local Format String Vuln in pam_ldap and remote in squid_auth_ldap.
  • C-Note Web site: C-Note::Software.
  • BID-4679: PAM_LDAP And Squid_Auth_LDAP Logging Format String Vulnerabilities
  • CVE-2002-0735: Format string vulnerability in the logging() function in C-Note Squid LDAP authentication module (squid_auth_LDAP) 2.0.2 and earlier allows remote attackers to cause a denial of service and possibly execute arbitrary code by triggering log messages.
  • OSVDB ID: 9905: Squid Proxy squid_auth_ldap logging() Format String

Platforms Affected:

  • Squid-Cache Squid 2.0.1

Reported:

May 06, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page