Phorum multiple PHP scripts could be used to execute commands

phorum-php-command-execution (9107) The risk level is classified as HighHigh Risk

Description:

Phorum could allow a remote attacker to execute arbitrary commands on the server. A remote attacker could send a specially-crafted URL request that uses the plugin.php, admin.php, or del.php scripts to specify arbitrary external PHP scripts that could be used to execute arbitrary commands on the affected Web server.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of Phorum (3.3.2b3 or later), available from the Phorum Web site. See References.

References:

Platforms Affected:

  • PHP Phorum 3.3.2a

Reported:

May 17, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page