lukemftp PASV command buffer overflow

lukemftp-pasv-bo (9130) The risk level is classified as HighHigh Risk

Description:

Lukemftp included with SuSE Linux is vulnerable to a buffer overflow, caused by improper parsing of the PASV FTP command. By sending a malformed PASV command to a connected FTP client running lukemftp, a remote attacker with control over a malicious FTP server could overflow a buffer on the client's system and execute arbitrary code on the system with privileges of the lukemftp user.


Consequences:

Gain Access

Remedy:

For SuSE Linux 6.4 (Intel, AXP Alpha, and PPC Power PC):
Upgrade to the latest nkitb package (2002.5.9-0 or later), as listed in SuSE Security Announcement SuSE-SA:2002:018. See References.

For SuSE Linux 7.0 (Intel, Sparc, AXP Alpha, and PPC Power PC):
Uprade to the latest nkitb and nkitserv packages (2002.5.8-0 or later), as listed in SuSE Security Announcement SuSE-SA:2002:018. See References.

For SuSE Linux 7.1 (Intel):
Upgrade to the latest version of lukemftp (1.5-251 or later), as listed in SuSE Security Announcement SuSE-SA:2002:018. See References.

For SuSE Linux 7.1 (Sparc):
Upgrade to the latest version of lukemftp (1.5-76 or later), as listed in SuSE Security Announcement SuSE-SA:2002:018. See References.

For SuSE Linux 7.1 (AXP Alpha):
Upgrade to the latest version of lukemftp (1.5-89 or later), as listed in SuSE Security Announcement SuSE-SA:2002:018. See References.

For SuSE Linux 7.1 (PPC Power PC):
Upgrade to the latest version of lukemftp (1.5-150 or later), as listed in SuSE Security Announcement SuSE-SA:2002:018. See References.

For SuSE Linux 7.2 and 7.3 (Intel):
Upgrade to the latest version of lukemftp (1.5-256 or later), as listed in SuSE Security Announcement SuSE-SA:2002:018. See References.

For SuSE Linux 7.3 (Sparc):
Upgrade to the latest version of lukemftp (1.5-77 or later), as listed in SuSE Security Announcement SuSE-SA:2002:018. See References.

For SuSE Linux 7.3 (PPC Power PC):
Upgrade to the latest version of lukemftp (1.5-154 or later), as listed in SuSE Security Announcement SuSE-SA:2002:018. See References.

For SuSE Linux 8.0 (Intel):
Upgrade to the latest version of lukemftp (1.5-249 or later), as listed in SuSE Security Announcement SuSE-SA:2002:018. See References.

References:

  • Freshmeat Web site: freshmeat.net: Project details for lukemftp.
  • CVE-2002-0768: Buffer overflow in lukemftp FTP client in SuSE 6.4 through 8.0, and possibly other operating systems, allows a malicious FTP server to execute arbitrary code via a long PASV command.
  • OSVDB ID: 5112: lukemftp FTP Client PASV Overflow

Platforms Affected:

  • Luke Mewburn lukemftp 1.5 and prior
  • SUSE SuSE Linux 6.4
  • SUSE SuSE Linux 7.0
  • SUSE SuSE Linux 7.1
  • SUSE SuSE Linux 7.2
  • SUSE SuSE Linux 7.3
  • SUSE SuSE Linux 8.0

Reported:

May 15, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page