CGIScript.net csNews information disclosure

cgiscript-csnews-information-disclosure (9331) The risk level is classified as LowLow Risk

Description:

csNews could allow a remote attacker to obtain sensitive information. A remote attacker could send a specially-crafted URL request to the script to cause an error message to display debug information, which could contain sensitive information including the full path to the Web root directory.


Consequences:

Obtain Information

Remedy:

No remedy available as of April 1, 2014.

References:

  • BugTraq Mailing List, Tue Jun 11 2002 - 16:00:51 CDT: CGIscript.net - csNews.cgi - Multiple Vulnerabilities.
  • CGIScript.net Web site: CGI Script.net - Webmaster Resource Site - Free and Professional CGI Scripts and JavaScripts.
  • CVE-2002-0921: CGIScript.net csNews.cgi allows remote attackers to obtain potentially sensitive information, such as the full server pathname and other configuration settings, via the viewnews command with an invalid database, which leaks the information in error messages.
  • OSVDB ID: 8131: CGIScript.net csNews.cgi Invalid Database Information Disclosure

Platforms Affected:

  • CGIScript csNews
  • CGIScript csNewsPro

Reported:

Jun 11, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page