SQL Server 2000 and Jet Engine OpenDataSource() buffer overflow

mssql-jet-ods-bo (9375) The risk level is classified as HighHigh Risk

Description:

Microsoft SQL Server 2000, Access 2000, and Access 2002 installed with Microsoft Jet 4.0 database engine is vulnerable to a buffer overflow in the OpenDataSource() function. By sending a specially-crafted SQL query containing the OpenDataSource() function, a remote attacker can overflow a buffer and execute arbitrary code on the system.


Consequences:

Gain Privileges

Remedy:

For vulnerability detection:

Enable the following checks in the ISS Protection Platform:
MssqlJetOdsBo

For Virtual Patch:

Enable the following checks in the ISS Protection Platform:
SQL_Jet_ODS_Overflow

Block or restrict the following Ports in the ISS Protection Platform as appropriate to the environment:
Port 1433

For Manual Protection:

Upgrade to the latest version of Microsoft Jet database engine (4.0 SP6 or later), as listed in NGSSoftware Insight Security Research Advisory #NISR19062002. See References.

References:

Platforms Affected:

  • Microsoft Access 2000
  • Microsoft Access 2002
  • Microsoft Jet 4.0
  • Microsoft SQL Server 2000

Reported:

May 27, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page