PHP multipart/form-data POST handler buffer overflow

php-multipart-handler-bo (9635) The risk level is classified as HighHigh Risk

Description:

PHP is vulnerable to a buffer overflow in the multipart/form-data handler code, which could allow a remote attacker to gain control over an affected Web server or cause a denial of service attack. By sending a malformed HTTP POST request, a remote attacker could overflow a buffer and execute arbitrary code on the Web server or possibly cause the Web server to crash.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of PHP (4.2.2 or later), available from the PHP Web site. See References.

For HP-UX 11.00, 11.11, 11.20, and 11.22:

Install the appropriate product bundle for your system, as listed in Hewlett-Packard Company Security Bulletin HPSBUX0208-207. See References.

For FreeBSD Ports Collection:
Upgrade to the latest ports collection, as listed in FreeBSD Security Notice FreeBSD-SN-02:05. See References.

References:

Platforms Affected:

  • FreeBSD FreeBSD Ports Collection
  • HP HP-UX 11
  • HP HP-UX 11.04
  • HP HP-UX 11.11
  • PHP PHP 4.2.0
  • PHP PHP 4.2.1

Reported:

Jul 22, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page