PostgreSQL cash_words() function buffer overflow

postgresql-cashwords-bo (9891) The risk level is classified as HighHigh Risk

Description:

PostgreSQL is vulnerable to a buffer overflow, caused by improper bounds checking of user-supplied input to the cash_words() function. By passing an overly long parameter to the cash_words() function and running a query that calls this function, a remote attacker could overflow a buffer and execute code on the system or cause the server to crash.


Consequences:

Gain Access

Remedy:

Upgrade to the latest version of PostgreSQL (7.2.1 or later), available from the PostgreSQL Inc. Web site. See References.

For Debian GNU/Linux:
Upgrade to the latest PostgreSQL packages, as listed below. Refer to DSA-165-1 for more information. See References.

Debian GNU/Linux 2.2: 6.5.3-27.2 or later
Debian GNU/Linux 3.0: 7.2.1-2woody2 or later

For Conectiva Linux:
Upgrade to the latest PostgreSQL package, as listed below. Refer to Conectiva Linux Announcement CLSA-2002:524 for more information. See References.

Conectiva Linux: 6.0: 7.0.3-11U60_2cl or later
Conectiva Linux: 7.0: 7.1.3-1U70_3cl or later
Conectiva Linux: 8.0: 7.2.2-1U80_2clor later

For Red Hat Linux 7.3:
Upgrade to the latest PostgreSQL package, as listed below. Refer to RHSA-2003:001-16 for more information. See References.

Red Hat 7.3: postgresql-7.2.3-5.73 or later

For Red Hat Linux 6.2, 7.0, 7.1, and 7.2:
Upgrade to the latest PostgreSQL package, as listed below. Refer to RHSA-2003:010-10 for more information. See References.

Red Hat Linux 6.2: postgresql-6.5.3-7.3 or later
Red Hat Linux 7.0: postgresql-7.0.2-18.2 or later
Red Hat Linux 7.1: postgresql-7.0.3-9.2 or later
Red Hat Linux 7.2: postgresql-7.1.3-4bp.2 or later

For Mandrake Linux:
Upgrade to the latest postgresql package, as listed below. Refer to MandrakeSoft Security Advisory MDKSA-2002:062-1:postgresql for more information. See References.

Mandrake Linux 7.2: 7.0.2-6.2mdk or later
Mandrake Linux 8.0: 7.0.3-12.3mdk or later
Mandrake Linux 8.1: 7.1.2-19.3mdk or later
Mandrake Linux 8.2: 7.2-12.2mdk or later
Mandrake Linux 9.0: 7.2.2-1.2mdk or later
Single Network Firewall 7.2: 7.0.2-6.2mdk or later

For Immunix OS 7+:
Upgrade to the latest version of postgresql (7.0.2-18.2_imnx_1 or later), as listed in Immunix OS Security Advisory IMNX-2003-7+-005-01. See References.

For other distributions:
Contact your vendor for upgrade or patch information.

References:

Platforms Affected:

  • Conectiva Linux 6.0
  • Conectiva Linux 7.0
  • Conectiva Linux 8.0
  • Debian Debian Linux 2.2
  • Debian Debian Linux 3.0
  • Immunix Immunix OS 7+-beta
  • Immunix Immunix OS 7.0
  • MandrakeSoft Mandrake Linux 7.2
  • MandrakeSoft Mandrake Linux 8.0
  • MandrakeSoft Mandrake Linux 8.1
  • MandrakeSoft Mandrake Linux 8.2
  • MandrakeSoft Mandrake Linux 9.0
  • MandrakeSoft Mandrake Single Network Firewall 7.2
  • PostgreSQL PostgreSQL 6.3.2
  • PostgreSQL PostgreSQL 6.5.3
  • PostgreSQL PostgreSQL 7.0.3
  • PostgreSQL PostgreSQL 7.1
  • PostgreSQL PostgreSQL 7.1.1
  • PostgreSQL PostgreSQL 7.1.2
  • PostgreSQL PostgreSQL 7.1.3
  • PostgreSQL PostgreSQL 7.2
  • RedHat Enterprise Linux 2.1 AS
  • RedHat Linux 6.2
  • RedHat Linux 7
  • RedHat Linux 7.1
  • RedHat Linux 7.2
  • RedHat Linux 7.3
  • RedHat Linux 8.0
  • RedHat Linux Advanced Workstation 2.1 Itanium

Reported:

Aug 19, 2002

The information within this database may change without notice. Use of this information constitutes acceptance for use in an AS IS condition. There are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the author/distributor (IBM Internet Security Systems X-Force) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

For corrections or additions please email ignore thisxforceignore this@ignore thisus.ignore thisibm.comignore this

Return to the main page